Mouse problem with VISTA

June 12, 2007

The keyboard issue is out, the other one is mouse.

I have a ComeMon optical mouse.    For some strange reasons it works only at 1 particular USB port.    VISTA won’t recognize it at any other USB ports.    At that special USB port 3 drivers, namely mouhid.sys moufiltr.sys and mouclass.sys, are used.    I managed to install the mouse at other USB ports manually but only 2 drivers (except moufiltr.sys) are needed.    The strange thing is that I have to do this manual installation at each and every USB port of my PC.

I’m not sure if this issue is related to this Help and Support article which suggests me to boot in safe mode to resolve this issue.

By the way my mouse isn’t of low power type, it needs 100mA, which doesn’t quite like my Microsoft Internet Keyboard which has a 2 port USB hub.

PS: Another possible cause of this problem was due to the Slide-Arch E-Blue keyboard which has a scroll wheel.    If this is installed in XP I got a driver automatically given by Windows update from a third party.    In VISTA this has caused a problem as the scroll wheel in the keyboard is considered a HID compliant mouse that isn’t recognized by VISTA.    I couldn’t find a VISTA driver yet for this keyboard.

Advertisements

Leave a Reply

Fill in your details below or click an icon to log in:

WordPress.com Logo

You are commenting using your WordPress.com account. Log Out / Change )

Twitter picture

You are commenting using your Twitter account. Log Out / Change )

Facebook photo

You are commenting using your Facebook account. Log Out / Change )

Google+ photo

You are commenting using your Google+ account. Log Out / Change )

Connecting to %s

%d bloggers like this: